diff --git a/net-im/utox/Manifest b/net-im/utox/Manifest
deleted file mode 100755
index b3d2f8c..0000000
--- a/net-im/utox/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST utox-0.16.0.tar.gz 2412270 SHA256 f2a09b6e9daae0152a08ae4085cfb2294ddcce8514a866134fee40dc0684dbe6 SHA512 d0ae6f20bdb99651a355d0d03b376497a6573cd62b379f010b8dc6192967bf43fb16066d2129f8368c62760361f659031133ed15e3908f81d5fc32f14a52b245 WHIRLPOOL c9b45fce564ac2562b0770a8cabfef63b3e23ab7d87b5c5c885b083f71953ed397523bf6d6e488707a4b359288b9c6893c6fd3869558f9c37ff3fec9a0696885
-DIST utox-0.16.1.tar.gz 2412331 SHA256 d8fcee0dbf25596e67c4323fc153069552eeeb4d99cdcdc09ca2074ebc38b493 SHA512 60350bf28b8ac067287550ce42bfb9b10502fbe94298ea9d4f00fb257bfc76c6cd9a7ef843719732e8d3e84789a391a95f3f1be732427b99ab8af472844e62a4 WHIRLPOOL b4e6be767d15ecd93010f95d4b58e3473d9fcff4b8929bbab62a09272694bdb780b8e2df8a348d49c4484a2b809c7e39e209840d990eef68c752599adec9aa67
diff --git a/net-im/utox/metadata.xml b/net-im/utox/metadata.xml
deleted file mode 100755
index 463b38c..0000000
--- a/net-im/utox/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-
-
-
-
- horea.christ@gmail.com
- Horea Christian
-
-
- proxy-maint@gentoo.org
- Proxy Maintainers
-
-
- A secure and lightning-fast messaging platform for the TOX protocol.
-
-
- uTox/uTox
-
-
-
-
diff --git a/net-im/utox/utox-0.16.0.ebuild b/net-im/utox/utox-0.16.0.ebuild
deleted file mode 100755
index 3bf351a..0000000
--- a/net-im/utox/utox-0.16.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit xdg-utils gnome2-utils cmake-utils
-
-DESCRIPTION="Lightweight Tox client"
-HOMEPAGE="https://utox.io"
-SRC_URI="https://github.com/uTox/uTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+dbus filter_audio test"
-KEYWORDS="~amd64"
-
-RDEPEND="net-libs/tox[av]
- media-libs/freetype
- filter_audio? ( media-libs/libfilteraudio )
- media-libs/libv4l
- media-libs/opus
- media-libs/libvpx
- x11-libs/libXrender
- media-libs/fontconfig
- media-libs/openal
- x11-libs/libX11
- x11-libs/libXext
- dbus? ( sys-apps/dbus )"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )
- virtual/pkgconfig"
-
-S=${WORKDIR}/uTox-${PV}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_FILTERAUDIO=$(usex filter_audio ON OFF)
- -DENABLE_DBUS=$(usex dbus ON OFF)
- -DENABLE_TESTS=$(usex test ON OFF)
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/net-im/utox/utox-0.16.1.ebuild b/net-im/utox/utox-0.16.1.ebuild
deleted file mode 100755
index 3bf351a..0000000
--- a/net-im/utox/utox-0.16.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit xdg-utils gnome2-utils cmake-utils
-
-DESCRIPTION="Lightweight Tox client"
-HOMEPAGE="https://utox.io"
-SRC_URI="https://github.com/uTox/uTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+dbus filter_audio test"
-KEYWORDS="~amd64"
-
-RDEPEND="net-libs/tox[av]
- media-libs/freetype
- filter_audio? ( media-libs/libfilteraudio )
- media-libs/libv4l
- media-libs/opus
- media-libs/libvpx
- x11-libs/libXrender
- media-libs/fontconfig
- media-libs/openal
- x11-libs/libX11
- x11-libs/libXext
- dbus? ( sys-apps/dbus )"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )
- virtual/pkgconfig"
-
-S=${WORKDIR}/uTox-${PV}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_FILTERAUDIO=$(usex filter_audio ON OFF)
- -DENABLE_DBUS=$(usex dbus ON OFF)
- -DENABLE_TESTS=$(usex test ON OFF)
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/net-im/utox/utox-9999.ebuild b/net-im/utox/utox-9999.ebuild
deleted file mode 100644
index 597896f..0000000
--- a/net-im/utox/utox-9999.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit git-r3 xdg-utils gnome2-utils cmake-utils
-
-DESCRIPTION="Lightweight Tox client"
-HOMEPAGE="https://utox.io"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/uTox/uTox.git"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+dbus filter_audio test"
-KEYWORDS=""
-
-RDEPEND="net-libs/tox[av]
- media-libs/freetype
- filter_audio? ( media-libs/libfilteraudio )
- media-libs/libv4l
- media-libs/opus
- media-libs/libvpx
- x11-libs/libXrender
- media-libs/fontconfig
- media-libs/openal
- x11-libs/libX11
- x11-libs/libXext
- dbus? ( sys-apps/dbus )"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )
- virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_FILTERAUDIO=$(usex filter_audio ON OFF)
- -DENABLE_DBUS=$(usex dbus ON OFF)
- -DENABLE_TESTS=$(usex test ON OFF)
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/net-libs/tox/ChangeLog b/net-libs/tox/ChangeLog
deleted file mode 100644
index 7065458..0000000
--- a/net-libs/tox/ChangeLog
+++ /dev/null
@@ -1,10 +0,0 @@
-*tox-0.1.6 (20 Jul 2018)
-*tox-0.2.3 (20 Jul 2018)
-*tox-0_pre20160904 (20 Jul 2018)
-*tox-9999 (20 Jul 2018)
-
- 20 Jul 2018; Horea Christian +files/confd, +files/initd,
- +files/tox-bootstrapd.conf, +files/tox-bootstrapd.service, +metadata.xml,
- +tox-0.1.6.ebuild, +tox-0.2.3.ebuild, +tox-0_pre20160904.ebuild,
- +tox-9999.ebuild:
- net-libs/tox: new package with attempted version bump
diff --git a/net-libs/tox/Manifest b/net-libs/tox/Manifest
deleted file mode 100644
index ec6739e..0000000
--- a/net-libs/tox/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST tox-0.1.6.tar.lz 314837 SHA256 c51dfaf30cddbfb9a6080c8202d68113452224570109cd9a6f1b7d9709eae6af SHA512 57ed7cee2c621c57e24f5ab36d68d99414d9820cdb3e8b7c4390818222f9d885f352f9cf76c8eb522c238bebc7d420bcf3cdd5f6ab65b9801aadbd225765166c WHIRLPOOL f75b27ade0f87f3793affbd291aba4b9e2387a29cd89deaf1351ed0797f634737938ff68d95a9fa1866891a68fa7a3b7f1c7ff0b68e3865eb7835fb9c4e5ff8b
-DIST tox-0.2.3.tar.gz 471336 SHA256 22c52f286c46d3f802edb6978bcf2a53f8301363e2b745784613427a33ba3a34 SHA512 25433cbbc0aa7e32174c8517a93c6351a23bd04cef34945876290bbd01e6074a5d7df2f5dcd39e67e3e18a6817346f98c45d55d789d462055643271ce44e49ee WHIRLPOOL 2a33e3d8e98d13b81a84248c7e289a321ab7e17ae438a17019d16b814f32f1545b86862cffc51c63353f7b9b9a2b2ba8e8394f4e9bfc7576a473ab59a3f240cd
-DIST tox-0_pre20160904.tar.gz 395495 SHA256 2d4a0d096bdb81b12b10551765fb9f87270e170f10f387f700b3def68cb6c35c SHA512 c0da52ac908141e97e96510a05431cbfb4b9aae81faf4c136c95e21b90a23e3bbe6db88303e48c0f4f3c74ca954229787564b7aa41bfb462afb0d8f8430cdaa1 WHIRLPOOL abd3f61784fac93d983e453515d1e8bc87f7d76651a53ce6f566a277d7ec7c1e03294d95781364ce9ab30f2698c6f5cd552bfa4888f8d5d0d315daf038980c63
diff --git a/net-libs/tox/files/confd b/net-libs/tox/files/confd
deleted file mode 100644
index 33f850b..0000000
--- a/net-libs/tox/files/confd
+++ /dev/null
@@ -1,2 +0,0 @@
-TOX_GROUP=tox
-TOX_USER=tox
diff --git a/net-libs/tox/files/initd b/net-libs/tox/files/initd
deleted file mode 100644
index 101d329..0000000
--- a/net-libs/tox/files/initd
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/sbin/openrc-run
-
-PIDDIR=/run/tox-bootstrapd
-PIDFILE="${PIDDIR}"/tox-bootstrap.pid
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting tox-dht-bootstrap daemon"
-
- checkpath -d -q -o "${TOX_USER}":"${TOX_GROUP}" "${PIDDIR}"
-
- start-stop-daemon --start \
- --pidfile "${PIDFILE}" \
- --user="${TOX_USER}" --group="${TOX_GROUP}" \
- --exec /usr/bin/tox-bootstrapd -- --config /etc/tox-bootstrapd.conf
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping tox-dht-bootstrap daemon"
-
- start-stop-daemon --stop \
- --pidfile "${PIDFILE}"
-
- eend $?
-}
diff --git a/net-libs/tox/files/tox-bootstrapd.conf b/net-libs/tox/files/tox-bootstrapd.conf
deleted file mode 100644
index 3413f59..0000000
--- a/net-libs/tox/files/tox-bootstrapd.conf
+++ /dev/null
@@ -1,65 +0,0 @@
-// Tox DHT bootstrap daemon configuration file.
-
-// Listening port (UDP).
-port = 33445
-
-// A key file is like a password, so keep it where no one can read it.
-// If there is no key file, a new one will be generated.
-// The daemon should have permission to read/write it.
-keys_file_path = "/var/lib/tox-bootstrapd/keys"
-
-// The PID file written to by the daemon.
-// Make sure that the user that daemon runs as has permissions to write to the
-// PID file.
-pid_file_path = "/var/run/tox-bootstrapd/tox-bootstrapd.pid"
-
-// Enable IPv6.
-enable_ipv6 = true
-
-// Fallback to IPv4 in case IPv6 fails.
-enable_ipv4_fallback = true
-
-// Automatically bootstrap with nodes on local area network.
-enable_lan_discovery = true
-
-enable_tcp_relay = true
-
-// While Tox uses 33445 port by default, 443 (https) and 3389 (rdp) ports are very
-// common among nodes, so it's encouraged to keep them in place.
-tcp_relay_ports = [443, 3389, 33445]
-
-// Reply to MOTD (Message Of The Day) requests.
-enable_motd = true
-
-// Just a message that is sent when someone requests MOTD.
-// Put anything you want, but note that it will be trimmed to fit into 255 bytes.
-motd = "tox-bootstrapd"
-
-// Any number of nodes the daemon will bootstrap itself off.
-//
-// Remember to replace the provided example with your own node list.
-// There is a maintained list of bootstrap nodes on Tox's wiki, if you need it
-// (https://wiki.tox.chat/users/nodes).
-//
-// You may leave the list empty or remove "bootstrap_nodes" completely,
-// in both cases this will be interpreted as if you don't want to bootstrap
-// from anyone.
-//
-// address = any IPv4 or IPv6 address and also any US-ASCII domain name.
-bootstrap_nodes = (
- { // Example Node 1 (IPv4)
- address = "127.0.0.1"
- port = 33445
- public_key = "728925473812C7AAC482BE7250BCCAD0B8CB9F737BF3D42ABD34459C1768F854"
- },
- { // Example Node 2 (IPv6)
- address = "::1/128"
- port = 33445
- public_key = "3E78BACF0F84235B30054B54898F56793E1DEF8BD46B1038B9D822E8460FAB67"
- },
- { // Example Node 3 (US-ASCII domain name)
- address = "example.org"
- port = 33445
- public_key = "8CD5A9BF0A6CE358BA36F7A653F99FA6B258FF756E490F52C1F98CC420F78858"
- }
-)
diff --git a/net-libs/tox/files/tox-bootstrapd.service b/net-libs/tox/files/tox-bootstrapd.service
deleted file mode 100644
index ae2f238..0000000
--- a/net-libs/tox/files/tox-bootstrapd.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Tox DHT Bootstrap Daemon
-After=network.target
-
-[Service]
-User=tox
-Group=tox
-RuntimeDirectory=tox-bootstrapd
-PIDFile=/run/tox-bootstrapd/tox-bootstrapd.pid
-WorkingDirectory=/var/lib/tox-bootstrapd
-ExecStart=/usr/bin/tox-bootstrapd --config /etc/tox-bootstrapd.conf
-#CapabilityBoundingSet=CAP_NET_BIND_SERVICE
-
-[Install]
-WantedBy=multi-user.target
diff --git a/net-libs/tox/metadata.xml b/net-libs/tox/metadata.xml
deleted file mode 100644
index 0dc9808..0000000
--- a/net-libs/tox/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-
-
-
-
-
-
- TokTok/c-toxcore
-
-
diff --git a/net-libs/tox/tox-0.1.6.ebuild b/net-libs/tox/tox-0.1.6.ebuild
deleted file mode 100644
index 62dd43f..0000000
--- a/net-libs/tox/tox-0.1.6.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools systemd unpacker user
-
-DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
-SRC_URI="https://github.com/TokTok/c-toxcore/releases/download/v${PV}/c-toxcore-v${PV}.tar.lz -> ${P}.tar.lz"
-
-LICENSE="GPL-3+"
-SLOT="0/0.1"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+av daemon log-debug log-error log-info log-trace log-warn +no-log ntox static-libs test"
-
-REQUIRED_USE="^^ ( no-log log-trace log-debug log-info log-warn log-error )"
-
-RDEPEND="
- av? ( media-libs/libvpx:=
- media-libs/opus )
- daemon? ( dev-libs/libconfig )
- ntox? ( sys-libs/ncurses:0= )
- >=dev-libs/libsodium-0.6.1:=[asm,urandom]"
-DEPEND="${RDEPEND}
- $(unpacker_src_uri_depends)
- test? ( dev-libs/check )
- virtual/pkgconfig"
-
-S=${WORKDIR}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(usex log-trace "--enable-logging --with-log-level=TRACE" "") \
- $(usex log-debug "--enable-logging --with-log-level=DEBUG" "") \
- $(usex log-info "--enable-logging --with-log-level=INFO" "") \
- $(usex log-warn "--enable-logging --with-log-level=WARNING" "") \
- $(usex log-error "--enable-logging --with-log-level=ERROR" "") \
- $(use_enable av) \
- $(use_enable test tests) \
- $(use_enable ntox) \
- $(use_enable daemon) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- if use daemon; then
- newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon
- insinto /etc
- doins "${FILESDIR}"/tox-bootstrapd.conf
- systemd_dounit "${FILESDIR}"/tox-bootstrapd.service
- fi
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- if use daemon; then
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- if [[ -f ${EROOT%/}/var/lib/tox-dht-bootstrap/key ]]; then
- ewarn "Backwards compatability with the bootstrap daemon might have been"
- ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT%/}/var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT%/}/etc/tox-bootstrapd.conf"
- ewarn " ${EROOT%/}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox"
- fi
- fi
-}
diff --git a/net-libs/tox/tox-0.2.3.ebuild b/net-libs/tox/tox-0.2.3.ebuild
deleted file mode 100644
index 02aa63d..0000000
--- a/net-libs/tox/tox-0.2.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools systemd unpacker user
-
-DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
-SRC_URI="https://github.com/TokTok/c-toxcore/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0/0.1"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+av daemon log-debug log-error log-info log-trace log-warn +no-log ntox static-libs test"
-
-REQUIRED_USE="^^ ( no-log log-trace log-debug log-info log-warn log-error )"
-
-RDEPEND="
- av? ( media-libs/libvpx:=
- media-libs/opus )
- daemon? ( dev-libs/libconfig )
- ntox? ( sys-libs/ncurses:0= )
- >=dev-libs/libsodium-0.6.1:=[asm,urandom]"
-DEPEND="${RDEPEND}
- $(unpacker_src_uri_depends)
- test? ( dev-libs/check )
- virtual/pkgconfig"
-
-S=${WORKDIR}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(usex log-trace "--enable-logging --with-log-level=TRACE" "") \
- $(usex log-debug "--enable-logging --with-log-level=DEBUG" "") \
- $(usex log-info "--enable-logging --with-log-level=INFO" "") \
- $(usex log-warn "--enable-logging --with-log-level=WARNING" "") \
- $(usex log-error "--enable-logging --with-log-level=ERROR" "") \
- $(use_enable av) \
- $(use_enable test tests) \
- $(use_enable ntox) \
- $(use_enable daemon) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- if use daemon; then
- newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon
- insinto /etc
- doins "${FILESDIR}"/tox-bootstrapd.conf
- systemd_dounit "${FILESDIR}"/tox-bootstrapd.service
- fi
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- if use daemon; then
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- if [[ -f ${EROOT%/}/var/lib/tox-dht-bootstrap/key ]]; then
- ewarn "Backwards compatability with the bootstrap daemon might have been"
- ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT%/}/var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT%/}/etc/tox-bootstrapd.conf"
- ewarn " ${EROOT%/}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox"
- fi
- fi
-}
diff --git a/net-libs/tox/tox-0_pre20160904.ebuild b/net-libs/tox/tox-0_pre20160904.ebuild
deleted file mode 100644
index 0d148a0..0000000
--- a/net-libs/tox/tox-0_pre20160904.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools systemd user vcs-snapshot
-
-DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
-EGIT_COMMIT="755f084e8720b349026c85afbad58954cb7ff1d4"
-SRC_URI="https://github.com/irungentoo/toxcore/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0/0.0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+av daemon log-debug log-error log-info log-trace log-warn +no-log ntox static-libs test"
-
-REQUIRED_USE="^^ ( no-log log-trace log-debug log-info log-warn log-error )"
-
-RDEPEND="
- av? ( media-libs/libvpx:=
- media-libs/opus )
- daemon? ( dev-libs/libconfig )
- ntox? ( sys-libs/ncurses:0= )
- >=dev-libs/libsodium-0.6.1:=[asm,urandom]"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )
- virtual/pkgconfig"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(usex log-trace "--enable-logging --with-log-level=TRACE" "") \
- $(usex log-debug "--enable-logging --with-log-level=DEBUG" "") \
- $(usex log-info "--enable-logging --with-log-level=INFO" "") \
- $(usex log-warn "--enable-logging --with-log-level=WARNING" "") \
- $(usex log-error "--enable-logging --with-log-level=ERROR" "") \
- $(use_enable av) \
- $(use_enable test tests) \
- $(use_enable ntox) \
- $(use_enable daemon) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- if use daemon; then
- newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon
- insinto /etc
- doins "${FILESDIR}"/tox-bootstrapd.conf
- systemd_dounit "${FILESDIR}"/tox-bootstrapd.service
- fi
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- if use daemon; then
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- if [[ -f ${EROOT}var/lib/tox-dht-bootstrap/key ]]; then
- ewarn "Backwards compatability with the bootstrap daemon might have been"
- ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT}var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT}etc/tox-bootstrapd.conf"
- ewarn " ${EROOT}run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox"
- fi
- fi
-}
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
deleted file mode 100644
index c3bf186..0000000
--- a/net-libs/tox/tox-9999.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools git-r3 user systemd
-
-DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/TokTok/c-toxcore.git"
-
-LICENSE="GPL-3+"
-SLOT="0/0.1"
-KEYWORDS=""
-IUSE="+av daemon log-debug log-error log-info log-trace log-warn +no-log ntox static-libs test"
-
-REQUIRED_USE="^^ ( no-log log-trace log-debug log-info log-warn log-error )"
-
-RDEPEND="
- av? ( media-libs/libvpx:=
- media-libs/opus )
- daemon? ( dev-libs/libconfig )
- ntox? ( sys-libs/ncurses:0= )
- >=dev-libs/libsodium-0.6.1:=[asm,urandom]"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )
- virtual/pkgconfig"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(usex log-trace "--enable-logging --with-log-level=TRACE" "") \
- $(usex log-debug "--enable-logging --with-log-level=DEBUG" "") \
- $(usex log-info "--enable-logging --with-log-level=INFO" "") \
- $(usex log-warn "--enable-logging --with-log-level=WARNING" "") \
- $(usex log-error "--enable-logging --with-log-level=ERROR" "") \
- $(use_enable av) \
- $(use_enable test tests) \
- $(use_enable ntox) \
- $(use_enable daemon) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- if use daemon; then
- newinitd "${FILESDIR}"/initd tox-dht-daemon
- newconfd "${FILESDIR}"/confd tox-dht-daemon
- insinto /etc
- doins "${FILESDIR}"/tox-bootstrapd.conf
- systemd_dounit "${FILESDIR}"/tox-bootstrapd.service
- fi
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- if use daemon; then
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- if [[ -f ${EROOT%/}/var/lib/tox-dht-bootstrap/key ]]; then
- ewarn "Backwards compatability with the bootstrap daemon might have been"
- ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT%/}/var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT%/}/etc/tox-bootstrapd.conf"
- ewarn " ${EROOT%/}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
- ewarn "Then just re-emerge net-libs/tox"
- fi
- fi
-}