mandelbulber ebuilds
This commit is contained in:
parent
b064165e51
commit
597d3cedde
1
media-gfx/mandelbulber/Manifest
Normal file
1
media-gfx/mandelbulber/Manifest
Normal file
@ -0,0 +1 @@
|
||||
DIST mandelbulber1.12-1.tar.gz 1179684 SHA256 75376616b52cb8dac7c7f358f4eb26f9d2fb171b9b0a54dbb25eeb57e494d382 SHA512 c198c71648ad4d674dac980c77fe2573617e122bdddb7775fccf74e1a929900691a421561f8717e4df741db65421cbdb8e464fd031ff5c38a56f63f5259b5512 WHIRLPOOL 7b5113bc81913607a544d19e9d16f53ec8888f97584110d0b8ad545b4603582f88fdfab4260d9fc74feaaae815739ac14f4b42e045fa1d6ae86d0e72e52f77fa
|
37
media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch
Normal file
37
media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch
Normal file
@ -0,0 +1,37 @@
|
||||
--- a/makefiles/makefile
|
||||
+++ b/makefiles/makefile
|
||||
@@ -5,6 +5,7 @@
|
||||
-include ../makefile.init
|
||||
|
||||
RM := rm -rf
|
||||
+CXX ?= g++
|
||||
|
||||
# All of the sources participating in the build are defined here
|
||||
-include sources.mk
|
||||
@@ -44,7 +45,7 @@
|
||||
mandelbulber: $(OBJS) $(USER_OBJS)
|
||||
@echo 'Building target: $@'
|
||||
@echo 'Invoking: GCC C++ Linker'
|
||||
- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS) `pkg-config --libs gtk+-2.0 gthread-2.0`
|
||||
+ $(CXX) $(LDFLAGS) -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS) `pkg-config --libs gtk+-2.0 gthread-2.0`
|
||||
@echo 'Finished building target: $@'
|
||||
@echo ' '
|
||||
|
||||
--- a/makefiles/src/subdir.mk
|
||||
+++ b/makefiles/src/subdir.mk
|
||||
@@ -63,12 +63,14 @@
|
||||
./src/undo.d \
|
||||
./src/cl_support.d
|
||||
|
||||
+CXX ?= g++
|
||||
+CXXFLAGS ?= -O2 -fast-math
|
||||
|
||||
# Each subdirectory must supply rules for building sources it contributes
|
||||
src/%.o: ../src/%.cpp
|
||||
@echo 'Building file: $<'
|
||||
@echo 'Invoking: GCC C++ Compiler'
|
||||
- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
|
||||
+ $(CXX) $(CXXFLAGS) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
|
||||
@echo 'Finished building: $<'
|
||||
@echo ' '
|
||||
|
@ -0,0 +1,22 @@
|
||||
http://bugs.gentoo.org/464972
|
||||
|
||||
--- src/texture.cpp
|
||||
+++ src/texture.cpp
|
||||
@@ -5,6 +5,7 @@
|
||||
* Author: krzysztof
|
||||
*/
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
#include "texture.hpp"
|
||||
#include "files.h"
|
||||
|
||||
--- src/timeline.cpp
|
||||
+++ src/timeline.cpp
|
||||
@@ -6,6 +6,7 @@
|
||||
*/
|
||||
|
||||
#include <cstdlib>
|
||||
+#include <cstring>
|
||||
|
||||
#include "timeline.hpp"
|
||||
#include "files.h"
|
48
media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild
Normal file
48
media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild
Normal file
@ -0,0 +1,48 @@
|
||||
# Copyright 1999-2013 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild,v 1.2 2013/04/08 15:05:56 ssuominen Exp $
|
||||
|
||||
EAPI=5
|
||||
inherit eutils toolchain-funcs versionator
|
||||
|
||||
MY_P=${PN}$(replace_version_separator 2 '-' )
|
||||
|
||||
DESCRIPTION="Tool to render 3D fractals"
|
||||
HOMEPAGE="http://sites.google.com/site/mandelbulber/home"
|
||||
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-3"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
|
||||
RDEPEND="x11-libs/gtk+:2
|
||||
>=media-libs/libsndfile-1
|
||||
>=media-libs/libpng-1.4:0=
|
||||
virtual/jpeg"
|
||||
DEPEND="${RDEPEND}
|
||||
virtual/pkgconfig"
|
||||
|
||||
S=${WORKDIR}/${MY_P}
|
||||
|
||||
src_prepare() {
|
||||
epatch \
|
||||
"${FILESDIR}"/${PN}-1.11-qa.patch \
|
||||
"${FILESDIR}"/${P}-memcpy_and_memset.patch
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
emake CXX="$(tc-getCXX)" -C makefiles all
|
||||
}
|
||||
|
||||
src_install() {
|
||||
dobin makefiles/${PN}
|
||||
dodoc README NEWS
|
||||
insinto /usr/share/${PN}
|
||||
doins -r usr/share/*
|
||||
domenu ${PN}.desktop
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
elog "Before you run ${PN} please copy /usr/share/${PN}/* to \${HOME}/.${PN}"
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user