dev-python/anys: moved to Gentoo Science
https://gitweb.gentoo.org/proj/sci.git/commit/?id=af3f0c4c30e2f2996de6c9b88155ec86e9e5f5cf
This commit is contained in:
parent
99d2f65540
commit
58eb8b1be8
@ -1,2 +0,0 @@
|
|||||||
DIST anys-0.2.0.tar.gz 17799 SHA256 cf8ca25b948ce0c6455d5eb40160334543ed818cdf51e5c3337020ec87bb25c0 SHA512 72bdc9df4cd805604f5497418a90738fccbc0ffd2dddf81324fe50d0d8ab13e036ff829e284dea8473427af396f02ceb01a191ad7d6946427478a12c04ca2ffd WHIRLPOOL 11da59490b36b55bed5c6401b34cc1259be8d6d5a58e2ba255f75ba824c6d9065aff6d7d41b3fa423be36afb4a43c75995014850e1acb90cadd244536960e1bc
|
|
||||||
DIST anys-0.2.1.tar.gz 17850 SHA256 f32e16ead49b0a96c530fe43aa4e69ffa68df1fd63042866a994618a08ae9725 SHA512 5a46d9e8aa97401f11dcc7a26a3d8dc759c59b5485222cb6ba1df3d4b2d8d67455102943f044850d289cd3e32bcaf6413ed4a4dfbee26c049a6ef32dfa5cd87e WHIRLPOOL d33d637b0028eb96fb87b60d69d29d351a0373fa5c270c353a96627178b36d6cea70980a14cdf0ec287ebd81d80533dce6b6c71dab03b9231bf0424452fbe4e6
|
|
@ -1,28 +0,0 @@
|
|||||||
# Copyright 1999-2022 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=8
|
|
||||||
|
|
||||||
PYTHON_COMPAT=( python3_{8..9} )
|
|
||||||
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
|
|
||||||
inherit distutils-r1
|
|
||||||
|
|
||||||
DESCRIPTION="Matchers for pytest"
|
|
||||||
HOMEPAGE="https://github.com/jwodder/anys"
|
|
||||||
SRC_URI="https://github.com/jwodder/anys/releases/download/v${PV}/${P}.tar.gz"
|
|
||||||
|
|
||||||
LICENSE="MIT"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~x86"
|
|
||||||
IUSE="test"
|
|
||||||
RESTRICT="!test? ( test )"
|
|
||||||
|
|
||||||
RDEPEND="
|
|
||||||
dev-python/wheel[${PYTHON_USEDEP}]
|
|
||||||
"
|
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/${PN}-0.2.0-coverage.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
distutils_enable_tests pytest
|
|
@ -1,28 +0,0 @@
|
|||||||
# Copyright 1999-2022 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=8
|
|
||||||
|
|
||||||
PYTHON_COMPAT=( python3_{8..10} )
|
|
||||||
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
|
|
||||||
inherit distutils-r1
|
|
||||||
|
|
||||||
DESCRIPTION="Matchers for pytest"
|
|
||||||
HOMEPAGE="https://github.com/jwodder/anys"
|
|
||||||
SRC_URI="https://github.com/jwodder/anys/releases/download/v${PV}/${P}.tar.gz"
|
|
||||||
|
|
||||||
LICENSE="MIT"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~x86"
|
|
||||||
IUSE="test"
|
|
||||||
RESTRICT="!test? ( test )"
|
|
||||||
|
|
||||||
RDEPEND="
|
|
||||||
dev-python/wheel[${PYTHON_USEDEP}]
|
|
||||||
"
|
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/${PN}-0.2.0-coverage.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
distutils_enable_tests pytest
|
|
@ -1,10 +0,0 @@
|
|||||||
--- a/tox.ini 2021-09-27 06:43:49.569561395 -0400
|
|
||||||
+++ b/tox.ini 2021-09-27 06:47:36.549815529 -0400
|
|
||||||
@@ -30,7 +30,6 @@
|
|
||||||
mypy src test
|
|
||||||
|
|
||||||
[pytest]
|
|
||||||
-addopts = --cov=anys --no-cov-on-fail
|
|
||||||
filterwarnings = error
|
|
||||||
norecursedirs = test/data
|
|
||||||
|
|
@ -1,16 +0,0 @@
|
|||||||
<?xml version='1.0' encoding='UTF-8'?>
|
|
||||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
|
||||||
<pkgmetadata>
|
|
||||||
<maintainer type="person">
|
|
||||||
<email>gentoo@chymera.eu</email>
|
|
||||||
<name>Horea Christian</name>
|
|
||||||
</maintainer>
|
|
||||||
<maintainer type="project">
|
|
||||||
<email>sci@gentoo.org</email>
|
|
||||||
<name>Gentoo Science Project</name>
|
|
||||||
</maintainer>
|
|
||||||
<upstream>
|
|
||||||
<remote-id type="github">jwodder/anys</remote-id>
|
|
||||||
<remote-id type="pypi">anys</remote-id>
|
|
||||||
</upstream>
|
|
||||||
</pkgmetadata>
|
|
Loading…
x
Reference in New Issue
Block a user