1
0
Fork 0

Merge branch 'master' of github.com:TheChymera/overlay

This commit is contained in:
Horea Christian 2019-01-06 11:57:37 +01:00
commit 53f01ef2de
7 changed files with 82 additions and 70 deletions

View File

@ -0,0 +1,18 @@
--- a/setup.py 2018-06-26 04:20:04.000000000 +0200
+++ b/setup.py 2018-11-06 17:47:28.940450375 +0100
@@ -105,6 +105,7 @@
"""
user_options = [
('skip-build', None, 'skip building the C/C++ code (assumes it has already been done)'),
+ ('parallel=', 'j', "number of parallel build jobs")
]
boolean_options = ['skip-build']
@@ -112,6 +113,7 @@
def initialize_options(self):
orig_build.initialize_options(self)
self.skip_build = '--skip-build' in sys.argv
+ self.parallel = None
def finalize_options(self):
orig_build.finalize_options(self)

View File

@ -0,0 +1,59 @@
--- a/wscript 2018-06-26 07:20:04.000000000 +0500
+++ b/wscript 2018-10-29 20:10:06.236956371 +0500
@@ -131,8 +131,8 @@
_copyEnvGroup(conf.env, '_WX', '_WXGL')
conf.env.LIB_WXGL += cfg.makeLibName('gl')
- _copyEnvGroup(conf.env, '_WX', '_WXWEBVIEW')
- conf.env.LIB_WXWEBVIEW += cfg.makeLibName('webview')
+ #_copyEnvGroup(conf.env, '_WX', '_WXWEBVIEW')
+ #conf.env.LIB_WXWEBVIEW += cfg.makeLibName('webview')
_copyEnvGroup(conf.env, '_WX', '_WXXML')
conf.env.LIB_WXXML += cfg.makeLibName('xml', isMSWBase=True)
@@ -220,16 +220,16 @@
uselib_store='WXGL', mandatory=True,
msg='Finding libs for WXGL')
- conf.check_cfg(path=conf.options.wx_config, package='',
- args='--cxxflags --libs webview,core,net' + rpath,
- uselib_store='WXWEBVIEW', mandatory=True,
- msg='Finding libs for WXWEBVIEW')
-
- if isDarwin:
- conf.check_cfg(path=conf.options.wx_config, package='',
- args='--cxxflags --libs core,net' + rpath,
- uselib_store='WXWEBKIT', mandatory=True,
- msg='Finding libs for WXWEBKIT')
+ #conf.check_cfg(path=conf.options.wx_config, package='',
+ # args='--cxxflags --libs webview,core,net' + rpath,
+ # uselib_store='WXWEBVIEW', mandatory=True,
+ # msg='Finding libs for WXWEBVIEW')
+
+ #if isDarwin:
+ # conf.check_cfg(path=conf.options.wx_config, package='',
+ # args='--cxxflags --libs core,net' + rpath,
+ # uselib_store='WXWEBKIT', mandatory=True,
+ # msg='Finding libs for WXWEBKIT')
conf.check_cfg(path=conf.options.wx_config, package='',
args='--cxxflags --libs xml,core,net' + rpath,
@@ -567,7 +567,7 @@
makeETGRule(bld, 'etg/_stc.py', '_stc', 'WXSTC')
makeETGRule(bld, 'etg/_html.py', '_html', 'WXHTML')
makeETGRule(bld, 'etg/_glcanvas.py', '_glcanvas', 'WXGL')
- makeETGRule(bld, 'etg/_html2.py', '_html2', 'WXWEBVIEW')
+ #makeETGRule(bld, 'etg/_html2.py', '_html2', 'WXWEBVIEW')
makeETGRule(bld, 'etg/_xml.py', '_xml', 'WXXML')
makeETGRule(bld, 'etg/_xrc.py', '_xrc', 'WXXRC')
makeETGRule(bld, 'etg/_richtext.py', '_richtext', 'WXHTML WXRICHTEXT')
@@ -577,8 +577,8 @@
makeETGRule(bld, 'etg/_aui.py', '_aui', 'WXAUI')
# Modules that are platform-specific
- if isDarwin:
- makeETGRule(bld, 'etg/_webkit.py', '_webkit', 'WXWEBKIT')
+ #if isDarwin:
+ #makeETGRule(bld, 'etg/_webkit.py', '_webkit', 'WXWEBKIT')
if isWindows:
makeETGRule(bld, 'etg/_msw.py', '_msw', 'WX')

View File

@ -41,6 +41,11 @@ DEPEND="
)
"
PATCHES=(
"${FILESDIR}/${PN}"-4.0.3-webkit.patch
"${FILESDIR}/${PN}"-4.0.3-parallel.patch
)
S="${WORKDIR}/${MY_PN}-${PV}"
python_prepare_all() {

View File

@ -1,5 +0,0 @@
*mouse-brain-atlases-0.5.3 (28 Dec 2018)
28 Dec 2018; Horea Christian <h.chr@mail.ru> +metadata.xml,
+mouse-brain-atlases-0.5.3.ebuild:
sci-biology/mouse-brain-atlases: version bump ahead of Gentoo Science

View File

@ -1,2 +0,0 @@
DIST mouse-brain-atlases-0.5.3.tar.xz 591935168 SHA256 ade5f957555d4ab4a1e679f8db7630911b2d3e6c7827d2e36ecd001f0deee333 SHA512 7d7ca79f99d03e4a9a97ccf6517fc6570770bee0cea80c2b31e7c4fb4500b8eb49ffb7df5579901c12dd982fd3efb6fc93490dcf53da715c167d47939ea44bdb WHIRLPOOL d1d73424b80b5fa9333a8db37362c22977e8aa3c7cf428d9062669f4fbb724e3dba5d11f598f61ed77fcd1328afca3dfea7f91f2cb3bee1fca28f638c393f233
DIST mouse-brain-atlasesHD-0.5.3.tar.xz 915990788 SHA256 b27ec957db076d20ce7c8f7ecf2748c84a7e2776a99371fc784079ca35ff74bd SHA512 46c74d41d323d4cdd7cdf5e8c8ceec03eecf5e7b5c83bb95b7ad4814e55dc32ada7f781710dc40145ffd751d650d35eb5727c460920b831135ab706f5e136718 WHIRLPOOL 7ec3e92fe6acee455c54587d90d92a330ca20d34df09ab02f5f46be01905e9c7c3e8a91a8ad7c44f8b8431150f52741cbcd57258f618f4a30b0776d19c0d1a06

View File

@ -1,19 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>horea.christ@gmail.com</email>
<name>Horea Christian</name>
</maintainer>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
Digital mouse brain atlases in NIfTI format for use in magnetic
resonance mouse brain imaging.
</longdescription>
<use>
<flag name="hires">Also install high-resolution atlases.</flag>
</use>
</pkgmetadata>

View File

@ -1,44 +0,0 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit check-reqs
DESCRIPTION="A collection of mouse brain atlases in NIfTI format"
HOMEPAGE="https://github.com/IBT-FMI/mouse-brain-atlases"
SRC_URI="
http://chymera.eu/distfiles/${P}.tar.xz
hires? ( http://chymera.eu/distfiles/${PN}HD-${PV}.tar.xz )
"
LICENSE="fairuse"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="hires"
RDEPEND=""
DEPEND=""
pkg_pretend() {
if use hires; then
CHECKREQS_DISK_BUILD="4G"
CHECKREQS_DISK_USR="4G"
CHECKREQS_DISK_VAR="8G"
else
CHECKREQS_DISK_BUILD="500M"
fi
check-reqs_pkg_pretend
}
# We disable this phase to not check requirements twice.
pkg_setup() { :; }
src_install() {
insinto "/usr/share/${PN}"
doins *
if use hires; then
cd "../${PN}HD-${PV}"
doins *
fi
}