dev-python/fslpy: version bump 2.6.2 ahead of Gentoo Science
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
006467726d
commit
3f9228690e
@ -1,3 +1,9 @@
|
||||
*fslpy-2.6.2 (04 Nov 2019)
|
||||
|
||||
04 Nov 2019; <chymera@gentoo.org> +files/fslpy-2.6.2-exclude_tests.patch,
|
||||
+fslpy-2.6.2.ebuild, -fslpy-1.11.1.ebuild, -fslpy-1.13.3.ebuild:
|
||||
dev-python/fslpy: version bump 2.6.2 ahead of Gentoo Science
|
||||
|
||||
*fslpy-1.11.1 (14 Oct 2018)
|
||||
|
||||
14 Oct 2018; Horea Christian <h.chr@mail.ru> +fslpy-1.11.1.ebuild,
|
||||
|
@ -1,2 +1 @@
|
||||
DIST fslpy-1.11.1.tar.gz 3444491 SHA256 033a1a4de6889d87e6db46a95173623272af84cce736d78244361e973de64a03 SHA512 b34640451a8bc94f7d0790095b343d2e93ead1145e5c31e2c7a831d5c08f3ae4e3f5120aa11f3dc2de734f69698d7102ce8caf80614759b15d1dd9047204aac8 WHIRLPOOL 174069b5826f3e8e5de57c8594cf68190ea808c2108e0c1f1a7f3e9451356774123ae2ea56cc4190eea95d0a72af346e4664343e4026fa274af53d729566e4c6
|
||||
DIST fslpy-1.13.3.tar.gz 3448291 SHA256 b3f4bf9646ecd61841744368013e84c5a0d7ae87a67104b067bed2418bb9ca69 SHA512 473a054807fe8ff6da588f8bfc0cc0faaee02438014ceb18fccbcf1ac1ba6c69a5cb18a6b810a7a5c5bd7d1298369419c83aff99cb07c1629391192feba76581 WHIRLPOOL 02998aa35e0d0e9b6eb6f7dedbd6bf314db340e70b8a2d29adbab549d127a8b6c1f4d5aa3193cbcb9c5bad5ce21fe21fdb94abcb93d3632b989b59cf647def79
|
||||
DIST fslpy-2.6.2.tar.gz 4643661 SHA256 9363f02678e7e9cb815352129ab72b6af392b22958b00bb375c57c98600bcd7f SHA512 42c48ec362dc0830486d862171e22b1d9336285f6cf12fc4735909b26802c206aaa090b8a6a1cfbd2f55fc041723a39f7544800c6e10d4b9a4a7ad41b9e12d2e WHIRLPOOL d0eccb3f834880bf964a249bbea23f39a6420babaef1baa646c5c8880709e5b56ec9fe3e607770464701f99a72d785111b88fb38abc3fa41a48547be43db8394
|
||||
|
10
dev-python/fslpy/files/fslpy-2.6.2-exclude_tests.patch
Normal file
10
dev-python/fslpy/files/fslpy-2.6.2-exclude_tests.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/setup.py 2019-11-04 18:56:47.407791008 +0100
|
||||
+++ b/setup.py 2019-11-04 20:00:24.844224851 +0100
|
||||
@@ -29,6 +29,6 @@
|
||||
|
||||
packages = find_packages(
|
||||
- exclude=('doc', 'tests', 'dist', 'build', 'fslpy.egg-info'))
|
||||
+ exclude=('doc', 'tests', 'tests.*', 'dist', 'build', 'fslpy.egg-info'))
|
||||
|
||||
# Figure out the current fslpy version, as defined in fsl/version.py. We
|
||||
# don't want to import the fsl package, as this may cause build problems.
|
@ -1,52 +0,0 @@
|
||||
# Copyright 1999-2018 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
PYTHON_COMPAT=( python2_7 python3_{5,6} )
|
||||
|
||||
inherit distutils-r1 virtualx
|
||||
|
||||
DESCRIPTION="The new FSL image viewer, released with FSL 5.0.10"
|
||||
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
||||
SRC_URI="https://github.com/pauldmccarthy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
DEPEND="
|
||||
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
"
|
||||
RDEPEND="
|
||||
dev-python/deprecation[${PYTHON_USEDEP}]
|
||||
=dev-python/numpy-1*[${PYTHON_USEDEP}]
|
||||
=dev-python/six-1*[${PYTHON_USEDEP}]
|
||||
dev-python/trimesh[${PYTHON_USEDEP}]
|
||||
dev-python/wxpython[${PYTHON_USEDEP}]
|
||||
sci-libs/Rtree[${PYTHON_USEDEP}]
|
||||
sci-libs/scipy[${PYTHON_USEDEP}]
|
||||
=sci-libs/nibabel-2*[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
# Tests fail on Gentoo with mysterious `Fatal Python error: deallocating None`
|
||||
# https://github.com/pauldmccarthy/fslpy/issues/3
|
||||
RESTRICT="test"
|
||||
|
||||
python_prepare_all() {
|
||||
if use test; then
|
||||
# Reported upstream
|
||||
# https://github.com/pauldmccarthy/fslpy/issues/3
|
||||
#sed -i -e \
|
||||
# "/def test_loadVestLutFile():/i@pytest.mark.xfail(reason='Known to fail on Gentoo')" \
|
||||
# tests/test_vest.py || die
|
||||
rm tests/test_vest.py
|
||||
fi
|
||||
distutils-r1_python_prepare_all
|
||||
}
|
||||
|
||||
python_test() {
|
||||
virtx pytest -m "not (dicomtest or fsltest)" --verbose || die
|
||||
}
|
@ -1,14 +1,14 @@
|
||||
# Copyright 1999-2018 Gentoo Authors
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
PYTHON_COMPAT=( python2_7 python3_{5,6} )
|
||||
PYTHON_COMPAT=( python3_{5,6} )
|
||||
|
||||
inherit distutils-r1 virtualx
|
||||
|
||||
DESCRIPTION="The new FSL image viewer, released with FSL 5.0.10"
|
||||
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
||||
DESCRIPTION="The FSL Python Library"
|
||||
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fslpy"
|
||||
SRC_URI="https://github.com/pauldmccarthy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD"
|
||||
@ -17,18 +17,23 @@ KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
DEPEND="
|
||||
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
|
||||
test? (
|
||||
dev-python/pytest[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-cov[${PYTHON_USEDEP}]
|
||||
)
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
"
|
||||
RDEPEND="
|
||||
dev-python/deprecation[${PYTHON_USEDEP}]
|
||||
dev-python/h5py[${PYTHON_USEDEP}]
|
||||
dev-python/indexed_gzip[${PYTHON_USEDEP}]
|
||||
=dev-python/numpy-1*[${PYTHON_USEDEP}]
|
||||
=dev-python/six-1*[${PYTHON_USEDEP}]
|
||||
dev-python/trimesh[${PYTHON_USEDEP}]
|
||||
dev-python/wxpython[${PYTHON_USEDEP}]
|
||||
sci-libs/Rtree[${PYTHON_USEDEP}]
|
||||
=dev-python/wxpython-4*[${PYTHON_USEDEP}]
|
||||
=sci-libs/Rtree-0.8.3*[${PYTHON_USEDEP}]
|
||||
sci-libs/scipy[${PYTHON_USEDEP}]
|
||||
=sci-libs/nibabel-2*[${PYTHON_USEDEP}]
|
||||
>=sci-libs/nibabel-2.3.1[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
# Tests fail on Gentoo with mysterious `Fatal Python error: deallocating None`
|
||||
@ -47,6 +52,8 @@ RDEPEND="
|
||||
# distutils-r1_python_prepare_all
|
||||
#}
|
||||
|
||||
PATCHES=( "${FILESDIR}/${P}-exclude_tests.patch" )
|
||||
|
||||
python_test() {
|
||||
virtx pytest -m "not (dicomtest or fsltest)" --verbose || die
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user