dev-vcs/dandi-cli: drop 0.37.0, 0.38.0, 0.39.4, 0.45.1
Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
4c08b8fc0a
commit
376275c0c7
@ -1,5 +1 @@
|
||||
DIST dandi-0.45.1.tar.gz 321362 SHA256 f68a06ade19ec3706d4bd6f973fd1e604f5baa5572bb50f8055a712f7fd7c59e SHA512 07d97420651bbd82d8d4146322ff80873489bd49869834ace9986f1ddc1880be5ff6bd1d625d8b4607a90de8007aeba152e8161af05c25a804cb18c7a0c78e29 WHIRLPOOL d5e46afbde3fa74a64478247ec60a46c4c1c01f071913886d827204c3706d2320903a658a354c99516b6f58a3407337c88128b021cbcdc5d2b7c1ce43b20718b
|
||||
DIST dandi-cli-0.37.0.tar.gz 212121 SHA256 4bf40a179d68ae4f0b28a5b62db6da8d14e17e9cb3b747162379cceab8055448 SHA512 fe96b760bb8526cf2670be4523121b389ede82699a8b13a9b46e4511012ab15390d9aec35b5403fa4d52dd79738a37980bcc83755df738b4039ae56eb6ca0f14 WHIRLPOOL 62a0fdc4f527bc246dd0452fd481e19bd07b146b9e118b8caa71227be78f5573649b0f55912cf54fe9606dc0de579692f94cc5a92f5c9a59a9d6c091bc3c068f
|
||||
DIST dandi-cli-0.38.0.tar.gz 322974 SHA256 654f9da46f9f81d8a023c62ecf4aa7cc42c20e677fc2073341df4b1a044523fc SHA512 a77d834dadbd532ce016425fe25324582a5d2c442b52087d5751770d99c84fa9532a08525ee75f40d45ccb5c50ed11b9fbe0c29a24c7d1b24c253d218538e054 WHIRLPOOL 00c3dbbc2673a6591e0b0c79339bb1320cf1471f2b667ee106590581d39b714ecd7ea94f148bb17a4e13a7f22204dba3ccd611b84002db09060b65a82d6fca5f
|
||||
DIST dandi-cli-0.39.4.tar.gz 329268 SHA256 cb6f6159eec29ea5e3436b948ef97107c756edfd68b700a4fbaacd4520760def SHA512 8ac4ae25eb9b09530a017ca2812a490c578157caeb0cca2737630f9796ec4559fc2379f150764544e1cd474cf481f87bb08dd255d4bf4dcc7722c8006ae78c4b WHIRLPOOL 29a1025339ac710a30461d51ea19794f37cec0435f9f715e8c433b50e5cf2018c022fb9ef4b0a5c761f3de8efde1896ab46e1ca2be2c0fc6295488d4bceb6f58
|
||||
DIST dandi-cli-0.45.1_p1.tar.gz 241015 SHA256 f8007eb3a2972bf1afecc0619ae61b4a92c6da3db3aba6f4f54b5b911bc9e4d0 SHA512 3294810f5e62f5466fe8b700733fea913e9ccaf4393b1fbb1d2ebe614f2ce5cc09dc92786f61f162b02b4415b662af2e49fd017061e4360a3626b7d76596a464 WHIRLPOOL f85489ac7b3e0904a6bac4d80170d0cadb1b87ea1f299a11265baff9114628773d9f69a29d8baafa193ccaf3c9f0903a267055dc8578b069ee24ab93405c70d3
|
||||
DIST 39bce6defa408ee89f3e00f7c2b3bad189faf24d.tar.gz 241015 SHA256 f8007eb3a2972bf1afecc0619ae61b4a92c6da3db3aba6f4f54b5b911bc9e4d0 SHA512 3294810f5e62f5466fe8b700733fea913e9ccaf4393b1fbb1d2ebe614f2ce5cc09dc92786f61f162b02b4415b662af2e49fd017061e4360a3626b7d76596a464 WHIRLPOOL f85489ac7b3e0904a6bac4d80170d0cadb1b87ea1f299a11265baff9114628773d9f69a29d8baafa193ccaf3c9f0903a267055dc8578b069ee24ab93405c70d3
|
||||
|
@ -1,87 +0,0 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
HOMEPAGE="https://github.com/dandi/dandi-cli"
|
||||
SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
~dev-python/dandi-schema-0.6.0[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
dev-python/interleave[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/keyring[${PYTHON_USEDEP}]
|
||||
dev-python/keyrings_alt[${PYTHON_USEDEP}]
|
||||
dev-python/packaging[${PYTHON_USEDEP}]
|
||||
dev-python/pycryptodome[${PYTHON_USEDEP}]
|
||||
>=dev-python/pydantic-1.9.0[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyout[${PYTHON_USEDEP}]
|
||||
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
|
||||
dev-python/semantic_version[${PYTHON_USEDEP}]
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/zarr[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
DEPEND="
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
dev-python/pyfakefs[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||
media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
# Upstream might be amenable to dropping opencv:
|
||||
# https://github.com/dandi/dandi-cli/issues/944
|
||||
|
||||
# Some tests require deep copy with git history
|
||||
# https://github.com/dandi/dandi-cli/issues/878#issuecomment-1021720299
|
||||
EPYTEST_DESELECT=(
|
||||
"dandi/tests/test_utils.py::test_get_instance_dandi_with_api"
|
||||
"dandi/tests/test_utils.py::test_get_instance_url"
|
||||
"dandi/tests/test_utils.py::test_get_instance_cli_version_too_old"
|
||||
"dandi/tests/test_utils.py::test_get_instance_bad_cli_version"
|
||||
)
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.37.0-pip-versioncheck.patch"
|
||||
"${FILESDIR}/${PN}-0.37.0-pep517.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
if use etelemetry; then
|
||||
default
|
||||
else
|
||||
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
|
||||
default
|
||||
sed -i "/etelemetry/d" setup.cfg
|
||||
fi
|
||||
}
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
epytest
|
||||
}
|
@ -1,87 +0,0 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
HOMEPAGE="https://github.com/dandi/dandi-cli"
|
||||
SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
~dev-python/dandi-schema-0.6.0[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
dev-python/interleave[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/keyring[${PYTHON_USEDEP}]
|
||||
dev-python/keyrings_alt[${PYTHON_USEDEP}]
|
||||
dev-python/packaging[${PYTHON_USEDEP}]
|
||||
dev-python/pycryptodome[${PYTHON_USEDEP}]
|
||||
>=dev-python/pydantic-1.9.0[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyout[${PYTHON_USEDEP}]
|
||||
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
|
||||
dev-python/semantic_version[${PYTHON_USEDEP}]
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/zarr[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
DEPEND="
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
dev-python/pyfakefs[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||
media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
# Upstream might be amenable to dropping opencv:
|
||||
# https://github.com/dandi/dandi-cli/issues/944
|
||||
|
||||
# Some tests require deep copy with git history
|
||||
# https://github.com/dandi/dandi-cli/issues/878#issuecomment-1021720299
|
||||
EPYTEST_DESELECT=(
|
||||
"dandi/tests/test_utils.py::test_get_instance_dandi_with_api"
|
||||
"dandi/tests/test_utils.py::test_get_instance_url"
|
||||
"dandi/tests/test_utils.py::test_get_instance_cli_version_too_old"
|
||||
"dandi/tests/test_utils.py::test_get_instance_bad_cli_version"
|
||||
)
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.37.0-pip-versioncheck.patch"
|
||||
"${FILESDIR}/${PN}-0.37.0-pep517.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
if use etelemetry; then
|
||||
default
|
||||
else
|
||||
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
|
||||
default
|
||||
sed -i "/etelemetry/d" setup.cfg
|
||||
fi
|
||||
}
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
epytest
|
||||
}
|
@ -1,88 +0,0 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
HOMEPAGE="https://github.com/dandi/dandi-cli"
|
||||
SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
~dev-python/dandi-schema-0.6.0[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
dev-python/interleave[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/keyring[${PYTHON_USEDEP}]
|
||||
dev-python/keyrings_alt[${PYTHON_USEDEP}]
|
||||
dev-python/nwbinspector[${PYTHON_USEDEP}]
|
||||
dev-python/packaging[${PYTHON_USEDEP}]
|
||||
dev-python/pycryptodome[${PYTHON_USEDEP}]
|
||||
>=dev-python/pydantic-1.9.0[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyout[${PYTHON_USEDEP}]
|
||||
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
|
||||
dev-python/semantic_version[${PYTHON_USEDEP}]
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/zarr[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
BDEPEND="
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
dev-python/pyfakefs[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||
media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
# Upstream might be amenable to dropping opencv:
|
||||
# https://github.com/dandi/dandi-cli/issues/944
|
||||
|
||||
# Some tests require deep copy with git history
|
||||
# https://github.com/dandi/dandi-cli/issues/878#issuecomment-1021720299
|
||||
EPYTEST_DESELECT=(
|
||||
"dandi/tests/test_utils.py::test_get_instance_dandi_with_api"
|
||||
"dandi/tests/test_utils.py::test_get_instance_url"
|
||||
"dandi/tests/test_utils.py::test_get_instance_cli_version_too_old"
|
||||
"dandi/tests/test_utils.py::test_get_instance_bad_cli_version"
|
||||
)
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.37.0-pip-versioncheck.patch"
|
||||
"${FILESDIR}/${PN}-0.37.0-pep517.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
if use etelemetry; then
|
||||
default
|
||||
else
|
||||
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
|
||||
default
|
||||
sed -i "/etelemetry/d" setup.cfg
|
||||
fi
|
||||
}
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
epytest
|
||||
}
|
@ -1,80 +0,0 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
MY_PN="dandi"
|
||||
MY_P="${MY_PN}-${PV}"
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
HOMEPAGE="https://github.com/dandi/dandi-cli"
|
||||
#SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
=dev-python/dandi-schema-0.7*[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
dev-python/interleave[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/keyring[${PYTHON_USEDEP}]
|
||||
dev-python/keyrings_alt[${PYTHON_USEDEP}]
|
||||
dev-python/nwbinspector[${PYTHON_USEDEP}]
|
||||
dev-python/packaging[${PYTHON_USEDEP}]
|
||||
dev-python/pycryptodome[${PYTHON_USEDEP}]
|
||||
>=dev-python/pydantic-1.9.0[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyout[${PYTHON_USEDEP}]
|
||||
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
|
||||
dev-python/semantic_version[${PYTHON_USEDEP}]
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/zarr[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
BDEPEND="
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
dev-python/pyfakefs[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||
media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
# Upstream might be amenable to dropping opencv:
|
||||
# https://github.com/dandi/dandi-cli/issues/944
|
||||
|
||||
S="${WORKDIR}/${MY_P}"
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
src_prepare() {
|
||||
if use etelemetry; then
|
||||
default
|
||||
else
|
||||
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
|
||||
default
|
||||
sed -i "/etelemetry/d" setup.cfg
|
||||
fi
|
||||
}
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
epytest
|
||||
}
|
@ -1,46 +0,0 @@
|
||||
From a363b68b79b3dd2004912640c90958882a918537 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
|
||||
Date: Wed, 4 May 2022 19:49:37 +0200
|
||||
Subject: [PATCH] Prepend to sys.path to fix versioneer in PEP517 mode
|
||||
|
||||
Prepend the current directory to sys.path rather than appending it
|
||||
in order to fix the build in PEP517 mode properly. If the path
|
||||
is appended and versioneer is installed on the system, the system
|
||||
versioneer.py (i.e. the module used to install versioneer into projects)
|
||||
is imported rather than the local file, and the build fails:
|
||||
|
||||
```
|
||||
Traceback (most recent call last):
|
||||
File "/usr/lib/python-exec/python3.10/gpep517", line 4, in <module>
|
||||
sys.exit(main())
|
||||
File "/usr/lib/python3.10/site-packages/gpep517/__main__.py", line 136, in main
|
||||
return func(args)
|
||||
File "/usr/lib/python3.10/site-packages/gpep517/__main__.py", line 44, in build_wheel
|
||||
wheel_name = backend.build_wheel(args.wheel_dir, args.config_json)
|
||||
File "/usr/lib/python3.10/site-packages/setuptools/build_meta.py", line 244, in build_wheel
|
||||
return self._build_with_temp_dir(['bdist_wheel'], '.whl',
|
||||
File "/usr/lib/python3.10/site-packages/setuptools/build_meta.py", line 229, in _build_with_temp_dir
|
||||
self.run_setup()
|
||||
File "/usr/lib/python3.10/site-packages/setuptools/build_meta.py", line 174, in run_setup
|
||||
exec(compile(code, __file__, 'exec'), locals())
|
||||
File "setup.py", line 32, in <module>
|
||||
"version": versioneer.get_version(),
|
||||
AttributeError: module 'versioneer' has no attribute 'get_version'
|
||||
```
|
||||
---
|
||||
setup.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index e8dddc985..05765009c 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -23,7 +23,7 @@
|
||||
# This is needed for versioneer to be importable when building with PEP 517.
|
||||
# See <https://github.com/warner/python-versioneer/issues/193> and links
|
||||
# therein for more information.
|
||||
-sys.path.append(os.path.dirname(__file__))
|
||||
+sys.path.insert(0, os.path.dirname(__file__))
|
||||
|
||||
try:
|
||||
import versioneer
|
@ -1,13 +0,0 @@
|
||||
--- a/setup.cfg 2021-10-06 11:44:40.549337707 -0400
|
||||
+++ b/dsetup.cfg 2021-10-06 11:45:10.236935245 -0400
|
||||
@@ -30,8 +30,8 @@
|
||||
appdirs
|
||||
click
|
||||
click-didyoumean
|
||||
- dandischema ~= 0.6.0
|
||||
- etelemetry >= 0.2.2
|
||||
+ dandischema
|
||||
+ etelemetry
|
||||
fasteners
|
||||
fscacher
|
||||
# Specifying != might be what causes pip 19.3.1 first to install hdmf 1.5.1
|
Loading…
x
Reference in New Issue
Block a user