Migrated to ::gentoo
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c18919d8279f0e28c4791d03ad2143abc9aff3e1
This commit is contained in:
parent
aa041998e9
commit
30357a59c3
@ -1,6 +0,0 @@
|
||||
*augustus-9999 (16 Mar 2021)
|
||||
|
||||
16 Mar 2021; <chymera@gentoo.org> +augustus-9999.ebuild,
|
||||
+files/augustus-2.0.1-uncapped.patch, -ChangeLog, -Manifest,
|
||||
-augustus-1.4.1a.ebuild, metadata.xml:
|
||||
games-strategy/augustus: live ebuild with proper system-wide dirs
|
@ -1,51 +0,0 @@
|
||||
# Copyright 1999-2021 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
inherit cmake git-r3 xdg
|
||||
|
||||
DESCRIPTION="Feature-enhanced open source re-implementation of Caesar III"
|
||||
HOMEPAGE="https://github.com/Keriew/augustus"
|
||||
EGIT_REPO_URI="https://github.com/Keriew/augustus.git"
|
||||
|
||||
LICENSE="AGPL-3"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~arm64"
|
||||
IUSE="uncapped"
|
||||
|
||||
DEPEND="
|
||||
media-libs/libpng:0=
|
||||
media-libs/libsdl2[joystick,video,sound]
|
||||
media-libs/sdl2-mixer
|
||||
"
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
src_prepare() {
|
||||
use uncapped && eapply "${FILESDIR}"/${PN}-2.0.1-uncapped.patch
|
||||
cmake_src_prepare
|
||||
xdg_src_prepare
|
||||
}
|
||||
|
||||
src_install() {
|
||||
insinto /etc/profile.d
|
||||
doins "${FILESDIR}"/90augustus.sh
|
||||
cmake_src_install
|
||||
mv "${ED}"/usr/bin/augustus "${ED}"/usr/bin/augustus-game ||
|
||||
die "Failed to rename executable (required as per conflict with sci-biology/augustus)"
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
xdg_pkg_postinst
|
||||
|
||||
ewarn "Augustus requires you to download the original Caesar 3 resources."
|
||||
ewarn
|
||||
ewarn "You need to obtain these files from a vendor of the proprietary software."
|
||||
ewarn "You will then need to copy the 'app' directory into '~/.cache/julius/'."
|
||||
ewarn "One way to obtain this directory is to download the GOG Cesar 3 edition."
|
||||
ewarn "You can then produce this directory by running:"
|
||||
ewarn " innoextract -m setup_caesar3_2.0.0.9.exe"
|
||||
ewarn
|
||||
ewarn "Lastly, run 'source /etc/profile' to refresh your environment and be able"
|
||||
ewarn "to start the game directly by running 'augustus-game' in the command line."
|
||||
}
|
@ -1,2 +0,0 @@
|
||||
#!/usr/bin/env bash
|
||||
alias augustus='augustus ~/.cache/julius/app'
|
@ -1,50 +0,0 @@
|
||||
From 1d3a24d74bbea85198c2c5d739a16dcc139af18b Mon Sep 17 00:00:00 2001
|
||||
From: Horea Christian <chr@chymera.eu>
|
||||
Date: Sat, 26 Dec 2020 12:59:15 -0500
|
||||
Subject: [PATCH] Limiting grand temple number to 6.
|
||||
|
||||
---
|
||||
src/building/construction.c | 2 +-
|
||||
src/building/construction_building.c | 2 +-
|
||||
src/widget/city_building_ghost.c | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/building/construction.c b/src/building/construction.c
|
||||
index d1ae9e9d4..eba378cdd 100644
|
||||
--- a/src/building/construction.c
|
||||
+++ b/src/building/construction.c
|
||||
@@ -595,7 +595,7 @@ void building_construction_update(int x, int y, int grid_offset)
|
||||
!(type == BUILDING_DISTRIBUTION_CENTER_UNUSED && city_buildings_has_distribution_center()) &&
|
||||
!(type == BUILDING_MESS_HALL && city_buildings_has_mess_hall()) &&
|
||||
!building_monument_has_monument(type) &&
|
||||
- !(building_monument_is_grand_temple(type) && building_monument_count_grand_temples() >= 2)) {
|
||||
+ !(building_monument_is_grand_temple(type) && building_monument_count_grand_temples() >= 6)) {
|
||||
int size = building_properties_for_type(type)->size;
|
||||
mark_construction(x, y, size, TERRAIN_ALL, 0);
|
||||
}
|
||||
diff --git a/src/building/construction_building.c b/src/building/construction_building.c
|
||||
index ed0d401c0..69e47f900 100644
|
||||
--- a/src/building/construction_building.c
|
||||
+++ b/src/building/construction_building.c
|
||||
@@ -749,7 +749,7 @@ int building_construction_place_building(building_type type, int x, int y)
|
||||
return 0;
|
||||
}
|
||||
|
||||
- if (building_monument_is_grand_temple(type) && building_monument_count_grand_temples() >= 2) {
|
||||
+ if (building_monument_is_grand_temple(type) && building_monument_count_grand_temples() >= 6) {
|
||||
city_warning_show(WARNING_MAX_GRAND_TEMPLES);
|
||||
return 0;
|
||||
}
|
||||
diff --git a/src/widget/city_building_ghost.c b/src/widget/city_building_ghost.c
|
||||
index 8fe9a30bf..c07bac64f 100644
|
||||
--- a/src/widget/city_building_ghost.c
|
||||
+++ b/src/widget/city_building_ghost.c
|
||||
@@ -303,7 +303,7 @@ static int is_fully_blocked(int map_x, int map_y, building_type type, int buildi
|
||||
if (building_monument_has_monument(type)) {
|
||||
return 1;
|
||||
}
|
||||
- if (building_monument_is_grand_temple(type) && building_monument_count_grand_temples() >= 2) {
|
||||
+ if (building_monument_is_grand_temple(type) && building_monument_count_grand_temples() >= 6) {
|
||||
return 1;
|
||||
}
|
||||
if (city_finance_out_of_money()) {
|
@ -1,20 +0,0 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>chr@chymera.eu</email>
|
||||
<name>Horea Christian</name>
|
||||
</maintainer>
|
||||
<longdescription lang="en">
|
||||
The aim of this project is to provide enhanced, customizable gameplay
|
||||
to Caesar 3 using project Julius UI enhancements. Augustus is able to
|
||||
load Caesar 3 and Julius saves, however saves made with Augustus will
|
||||
not work outside Augustus.
|
||||
</longdescription>
|
||||
<upstream>
|
||||
<remote-id type="github">Keriew/augustus</remote-id>
|
||||
</upstream>
|
||||
<use>
|
||||
<flag name='uncapped'>Uncap grand temple count</flag>
|
||||
</use>
|
||||
</pkgmetadata>
|
Loading…
x
Reference in New Issue
Block a user