dev-vcs/dandi-cli: version bump
Tests fail: https://github.com/dandi/dandi-cli/issues/878 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
ece8431112
commit
10efd05a08
@ -1,3 +1,12 @@
|
||||
*dandi-cli-0.34.1 (25 Jan 2022)
|
||||
*dandi-cli-0.35.0 (25 Jan 2022)
|
||||
|
||||
25 Jan 2022; <chymera@gentoo.org> +dandi-cli-0.34.1.ebuild,
|
||||
+dandi-cli-0.35.0.ebuild, +files/dandi-cli-0.34.1-pip-versioncheck.patch,
|
||||
dandi-cli-0.31.0.ebuild:
|
||||
dev-vcs/dandi-cli: version bump Tests fail: https://github.com/dandi/dandi-
|
||||
cli/issues/878
|
||||
|
||||
*dandi-cli-0.31.0 (29 Oct 2021)
|
||||
|
||||
29 Oct 2021; <chymera@gentoo.org> +dandi-cli-0.31.0.ebuild,
|
||||
|
@ -1,3 +1,5 @@
|
||||
DIST dandi-cli-0.28.0.tar.gz 173403 SHA256 27b67c93a8625dd15db2e3513ae3448569ccade2dc82eb1f110de5b1c02b5ec3 SHA512 399ee378798a3c7fdc92314dca25e91178bb157145205e43a1d2ec461f36c674ed1b63b97f805ab9d25eb30d18d82827e38024b8a72c691c3992af60fc286be3 WHIRLPOOL 3381c9f7f0c7c5263bb2a8019205a44d0b6084fc9719034462ea7d66f0f23a617dfc3468676102f931444b4b43b788e8c7c65615ebae5f30c635d51badbaf92a
|
||||
DIST dandi-cli-0.30.3.tar.gz 175911 SHA256 ed218df35ee69f6d06fd6c70fe69226aaf6d3231f8b58abdd1b9fd1477350c44 SHA512 11e73a5acaa05bb2d0287e25e1e25226474f5b076ac58e9bedcb1608e6a509d113960a1d6dfe1b665d99d14d6b4b51f65eb85c38a4f9eba0ddb5492f1890cf96 WHIRLPOOL f12b8c0eada3b6ddf373301e8cfd1b1c1c4339d4ee59fe37b730eb7c91a4c031660da422316c007ce5445d2ab90c83242921cc417dad43c66bad814031811946
|
||||
DIST dandi-cli-0.31.0.tar.gz 179090 SHA256 6bc9a46e90da1b6b11fcc1492c02223f135ce5a1f42747df8f5cb09fe6cb1c10 SHA512 5c72b0a75469c3f5762a653b454797723251b108c770ad617f814983691f5205c02302a444dc5650754597537d6dd75a3bc84d886a557243d489d738e3033981 WHIRLPOOL 2d2d1ad8e392f0ec0dd707963618cda3e524bd6efbd2240c8fec2fd5bec3ca15f47740a6b96c47f4f4ec05f4abd6fae90875b95fa272d79d42b305385fcafc35
|
||||
DIST dandi-cli-0.34.1.tar.gz 179765 SHA256 7b8ef65b49c6adb42c927018214f11a9c549ba6297373c929b551e1443ca95c0 SHA512 c6e42052a3bbce374589eea43f3cef9525f2d95b555731dc2899f432567c92ab6425a59b131f22f547b9e74a6225462e2dc50a7c3f1b707e17fb49e75d2e0d55 WHIRLPOOL 89b9aa5b6682d4ba2c0b035ea90ad5b77fc025cb7cfd474dc8d41297e3efc567c1ded27751912c0b588f87927a117984889907c60b49dda80eb26bac8be1c93b
|
||||
DIST dandi-cli-0.35.0.tar.gz 180324 SHA256 c05706225096cc2357552c822d6c8da985b553d2b0406415cc0037acac50222f SHA512 07689e678d064501ec6879eeb40389c87491cbde4321b382c5c1041b9a8228845086978629327a9b271b5ac62f4c66e4d3c32c1edffead93ec66ce4d03b96d9a WHIRLPOOL bd970e1983a49a7af547431fb2717cf706884fcc232698b548d687d4971699da49bff818a64081f8d83628f165996fa40182331f740933e87d69cffcd4d85d06
|
||||
|
@ -1,4 +1,4 @@
|
||||
# Copyright 1999-2021 Gentoo Authors
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
@ -40,6 +40,7 @@ RDEPEND="
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/tqdm[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
<dev-python/jsonschema-4[${PYTHON_USEDEP}]
|
||||
"
|
||||
# Errors with newer jsonschema, though not a direct dependency, reported upstream:
|
||||
# https://github.com/dandi/dandi-cli/issues/825
|
||||
|
77
dev-vcs/dandi-cli/dandi-cli-0.34.1.ebuild
Normal file
77
dev-vcs/dandi-cli/dandi-cli-0.34.1.ebuild
Normal file
@ -0,0 +1,77 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
HOMEPAGE="https://github.com/dandi/dandi-cli"
|
||||
SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
#RESTRICT="test"
|
||||
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
=dev-python/dandischema-0.5*[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/keyring[${PYTHON_USEDEP}]
|
||||
dev-python/keyrings_alt[${PYTHON_USEDEP}]
|
||||
dev-python/packaging[${PYTHON_USEDEP}]
|
||||
dev-python/pycryptodomex[${PYTHON_USEDEP}]
|
||||
dev-python/pydantic[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyout[${PYTHON_USEDEP}]
|
||||
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
|
||||
dev-python/semantic_version[${PYTHON_USEDEP}]
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/tqdm[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
"
|
||||
#<dev-python/jsonschema-4[${PYTHON_USEDEP}]
|
||||
# Errors with newer jsonschema, though not a direct dependency, reported upstream:
|
||||
# https://github.com/dandi/dandi-cli/issues/825
|
||||
|
||||
DEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
dev-python/pyfakefs[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${P}-pip-versioncheck.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
if use etelemetry; then
|
||||
default
|
||||
else
|
||||
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
|
||||
default
|
||||
sed -i "/etelemetry/d" setup.cfg
|
||||
fi
|
||||
}
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
${EPYTHON} -m pytest -vv || die "Tests failed with ${EPYTHON}"
|
||||
}
|
77
dev-vcs/dandi-cli/dandi-cli-0.35.0.ebuild
Normal file
77
dev-vcs/dandi-cli/dandi-cli-0.35.0.ebuild
Normal file
@ -0,0 +1,77 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
HOMEPAGE="https://github.com/dandi/dandi-cli"
|
||||
SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
#RESTRICT="test"
|
||||
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
=dev-python/dandischema-0.5*[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/keyring[${PYTHON_USEDEP}]
|
||||
dev-python/keyrings_alt[${PYTHON_USEDEP}]
|
||||
dev-python/packaging[${PYTHON_USEDEP}]
|
||||
dev-python/pycryptodomex[${PYTHON_USEDEP}]
|
||||
dev-python/pydantic[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyout[${PYTHON_USEDEP}]
|
||||
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
|
||||
dev-python/semantic_version[${PYTHON_USEDEP}]
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/tqdm[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
"
|
||||
#<dev-python/jsonschema-4[${PYTHON_USEDEP}]
|
||||
# Errors with newer jsonschema, though not a direct dependency, reported upstream:
|
||||
# https://github.com/dandi/dandi-cli/issues/825
|
||||
|
||||
DEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
dev-python/pyfakefs[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.34.1-pip-versioncheck.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
if use etelemetry; then
|
||||
default
|
||||
else
|
||||
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
|
||||
default
|
||||
sed -i "/etelemetry/d" setup.cfg
|
||||
fi
|
||||
}
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
${EPYTHON} -m pytest -vv || die "Tests failed with ${EPYTHON}"
|
||||
}
|
@ -0,0 +1,13 @@
|
||||
--- a/setup.cfg 2021-10-06 11:44:40.549337707 -0400
|
||||
+++ b/dsetup.cfg 2021-10-06 11:45:10.236935245 -0400
|
||||
@@ -30,8 +30,8 @@
|
||||
appdirs
|
||||
click
|
||||
click-didyoumean
|
||||
- dandischema ~= 0.5.1
|
||||
- etelemetry >= 0.2.2
|
||||
+ dandischema
|
||||
+ etelemetry
|
||||
fasteners
|
||||
fscacher
|
||||
# Specifying != might be what causes pip 19.3.1 first to install hdmf 1.5.1
|
Loading…
x
Reference in New Issue
Block a user